A reserved or maintenance trip cannot exceed 100 days / Access Violation / Requested key not found

A reserved or maintenance trip cannot exceed 100 days / Access Violation / Requested key not found

Errors:
A reserved or maintenance trip cannot exceed 100 days. Trip end date has been automatically adjusted. You may create a second trip after this trip if 100 days is not sufficient.



Access violation at address 0090C310 in module 'Fos.exe'. Read of address 00000100.



Requested key not found (error=4) 
tripdata_unlocklegs: tripleg_unlock_record (Thread 0)



Cause:

FOS currently allows you to enter an end date prior to the begin date entered for trips with no itinerary. The impacts are three-fold. This has been experienced on 3.11.10.5 through 3.11.13.3 (test). 

1) When that trip is saved, it disappears from the schedule board and can only be found again scrolling through the trips list. 

2) The errors above begin to occur when the actions above take place prior. However, after correcting the end date to one after the begin date....and if the trip is longer than 100 days...you begin to receive the following chain of error messages and subsequently locked in FOS with no way to exit other than ending task in task manager. 

3) Additional testing showed that if a trip is scheduled over 199 days, you would also get this warning, and then no longer be able to edit appropriately without getting these warnings. 



Solutions: 

1) After clearing FOS session and logging back in, open the trip and edit the range to one that is less than 100 days and in correct sequence. 


Alternatively, you can delete the trip in question (causing the errors) and re-create using appropriate date range (make sure end date is later than begin date). *** Recommended *** 

NOTE: If a trip with no itinerary is created with a date range in the proper sequence, you may still get the 100 day limit for trips that exceed 199 days.